Liteloader Mod 1.12.2 for Minecraft 1.12.2 Download

20
132939

Liteloader Mod Overview

Liteloader Mod 1.12.2/1.11.2 is a very lightweight modloader and bootstrap designed to provide very basic loader functionality for mods in Minecraft which don’t need to modify game mechanics. It is designed to run alongside Minecraft Forge and Forge Mod Loader (FML) and LiteLoader mods will virtually never conflict with Forge mods. This tool is perfect for client-side mods like Mini Maps, Chat Tools, and HUD mods. It is very easy to install and compatible with all launchers supporting the Mojang Tweak System.

LiteLoader

Minecraft is a game of many resource packs and mods, highly customizable and easy to tailor to whatever specific vision you may have in your mind for how the world should look and feel. However, to keep all those additions working correctly, you need things like the LiteLoader tool, which is essentially a modloader like MCPatcher, Forge, and other loaders. Just like these other tools, this one is unique in a couple ways, but mostly the same. There are mods designed specifically for use with LiteLoader, but Minecraft Forge is probably the most popular modloader in the world, so keep that in mind.

Features:

  • Simple, easy-to-use client modding API, perfect for client-side mods like Mini Maps, Chat Tools, and other HUD mods.
  • Bytecode-based event injection system which provides super-efficient event handling, and can be easily extended by mods as necessary.
  • Compatibile with Minecraft Forge and FML thanks to dynamic injection.
  • Built-in mod version validation which allows LiteLoader to identify and load only valid mods – no more crashes caused by accidentally loading out-of-date mods.
  • Easy to install and compatible with all launchers supporting the Mojang Tweak System (launchwrapper).
  • Extensible “LiteAPI” core allows more complex APIs such as BlazeLoader to be built on top of LiteLoader.
  • Sleek in-game user interface provides mod management, mod configuration panels, error reporting and in-game log viewer:

LiteLoader
LiteLoader

Update Logs:

  • Update to launchwrapper 1.12.2/1.11.2 and ASM 5.03 to support Java 8.
  • Fix a problem with the mod dependency check which caused a crash.
  • Deprecate some interfaces ready for 1.11 transition.

How to Install Liteloader Mod?

  1. Make sure you have already installed Minecraft Forge API.
  2. Open Minecraft launcher then select Forge profile.
  3. Find your minecraft application folder:
    On Windows, open Run from the start menu, type %appdata%\.minecraft\ and click Run. On Mac, open Finder, hold down ALT and click Go then Library in the top menu bar. Open the folder Application Support and look for minecraft.
  4. Place Liteloader Mod into your Mods folder. If you don't have one, create it now.

Download for Minecraft 1.12.2 and Other Versions

Before installing Liteloader Mod, you must download it. Before downloading anything, please agree to the following rules:

  • We do not host any Minecraft resources (mods, textures...) on our website.
  • We do not modify or edit the files in any way.
  • If you have any problem, please leave a comment below and we will help you.


20 COMMENTS

  1. Why on earth are there still idiots who lend their webpage for lying shitheads! 1.12…. Come on people, be realistic or go work the rest of your life as a cash register cunt!

    • Where did you find any download for Liteloader 1.9? I can’t find that. Please can you send me yours so i can use it for my Minecraft? Thanx!

    • That’s resoundingly not helpful. The downloader on their site says for 1.7.10. Is that downloader compatible with 1.9?

  2. People of the web “I have done it” iv found liteloader 1.9. But the only problem is some of the mods i use are still 1.8 and are not going to be getting updated so heres the deal. someone find me a “how to update a liteloader mods” and i will post the link.

    Please help me

    Deal?? or no Deal??

    😀

  3. If it isn’t 1.9 ready, it shouldn’t be tagged as 1.9. Nor should update notes for 1.9 be fabricated if the developers haven’t even gotten past 1.8 yet. All things like this do is cause annoyances.

POST A COMMENT

Please enter your comment!
Please enter your name here